This topic contains 10 replies, has 2 voices, and was last updated by  Artem 9 months, 1 week ago.

Google font https error

  • I get browser security error:

    “The page at ‘https://www…..’ was loaded over HTTPS, but requested an insecure stylesheet ‘http://fonts.googleapis.com css?family=Arvo:300italic,400italic,600italic,7…0|&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese’. This request has been blocked; the content must be served over HTTPS.”

    It seems that the theme is looking for google fonts at http://fonts.googleapis.com instead of https://fonts.googleapis.com

    How/where do I change this? It doesn’t matter which font I choose in the theme options.

    Hi,
    Give us a screenshot of your problem and link to your site.

    This reply has been marked as private.

    Also – I can never preview any font in Theme Options. THe font on the “chalkboard” never changes, even if I save. See screen shot #2.

    Attachments:
    You must be logged in to view attached files.

    We have just tested the New!Shop theme. Everything works perfectly. You can see it from the screenshots that we made.
    Your problem may be caused for many reasons: the changes you’ve made in our theme, the possible incompatibility of plug-ins, hosting settings, etc.
    We can’t diagnose the problem more precisely without access to your site.

    Attachments:
    You must be logged in to view attached files.

    Are you accessing it thru a secure site hhtpS : – not httP : ?

    I fixed the google font error last night, by changing http : to httpS : for the google fonts address in the Enqueue CSS & Scripts section of clean.php. That worked.

    BUT, the preview still does not work. Can you tell me where I can find the code for the text preview, so I can also change it to httpS ?

    Sorry if I posted this twice. I don’t think it posted the first time…

    This reply has been marked as private.

    Thank you. That worked. Now I am also having the same httpS problem with the favicon files (I have to remove the “S” to get the image to show, but then I get an html error message). And with the header/home button logo image.

    All images are loaded from the theme media library.

    Can you send me the file info to have the theme look in httpS for the image instead of httP?

    Thanks!

    This reply has been marked as private.

    I am not trying to “modify it at will”. I am trying to stop error messages.

    The woocommerce links do not do this. Only the theme links do it.

    Hi,
    Any WordPress theme is not originally prepared to work on https. In order for the theme to work on https it is necessary to take a lot of steps, and this is the reworking of the theme. It is not the scope of our support. We do not provide support, in that case, if the buyer begins to change code in the theme by himself. Initially, the theme works fine and all errors have arisen as a result of your activities inside the theme. If you want to customize the theme to work on https, refer to the help of developers. Or try to do it yourself by following the instructions from the links below.

    https://www.keycdn.com/blog/http-to-https/

    http://www.wpbeginner.com/wp-tutorials/how-to-add-ssl-and-https-in-wordpress/

    https://designmodo.com/wordpress-https/

    https://css-tricks.com/moving-to-https-on-wordpress/

    Best Regards,
    RFC Support Team

Tagged: 

You must be logged in to reply to this topic.